Installation

Last updated 2 months ago

Hurray, you are interested and ready to get going! But slow down, you're going to need to have some things installed before you start.

Prerequisites

  • Node (preferably version 8 or higher)

  • npm

Installation

If you are really into using this tool or don't like downloading it every time you want to use it, then I recommend you install it globally.

# You should only install "deploy-to-1mb" once unless upgrading.
npm install --global deploy-to-1mb
# Use this command to deploy your website.
deploy-to-1mb

However, if you would rather just test it out, then I would recommend that you just execute the package binaries every time using the following command.

# You do not need to worry about installing globally, or related permissions.
npx deploy-to-1mb